Impaired call quality to MTN numbers
Incident Report for Sudonum
Resolved
We are seeing a reduction in call congestion to MTN destinations as a result of reduced load shedding stages and measures put in place by MTN.

We will however continue to monitor call statistics for quality degradation.
Posted Jul 12, 2022 - 12:19 SAST
Identified
Upstream vendors have confirmed MTN is currently experiencing congestion across their network as a result of the increased load shedding.

We expect this to continue until load shedding is reduced.
Posted Jun 28, 2022 - 17:26 SAST
This incident affected: External connectivity (Voice - South Africa).