MTN Voice Connectivity Issue to 278772 Number Range
Incident Report for Sudonum
Resolved
This issue has been resolved by the operator and inbound calls to our South African 278772 number range from MTN are now working as intended.

We will continue to monitor calling traffic.

Apologies for any inconvenience caused.
Posted Sep 17, 2020 - 19:55 SAST
Investigating
Calls to our 278772 number range from MTN numbers are currently degraded due to an interconnect drop.

Investigations are underway with the operator.
Posted Sep 17, 2020 - 09:09 SAST
This incident affected: Numbers.