Calls to the MTN Network are failing
Incident Report for Sudonum
Resolved
Calls to the MTN Network are clearing normally.
Posted Mar 27, 2020 - 22:59 SAST
Monitoring
It appears that MTNs Network is stable again. Our team will monitor voice and SMS traffic for the next 30min to make sure all traffic is nominal.
Posted Mar 27, 2020 - 19:54 SAST
Investigating
MTN South Africa is experiencing network problems which are causing calls to mobile phones on its network to fail. The problems started shortly before 15:00 SAST on Friday and seem to affect calls from all networks, including MTN itself, to MTN subscribers.
Posted Mar 27, 2020 - 16:51 SAST
This incident affected: Voice call and Numbers.